summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Jones <admin@danieljon.es>2020-08-16 22:01:10 +0930
committerDaniel Jones <admin@danieljon.es>2020-08-16 22:01:10 +0930
commiteb19009d216f4fb0f7911b939b2f1bc698e40c79 (patch)
tree311aec5b03341c301bacaff7a424cbbfd58ce898 /CMakeLists.txt
downloadchip8-eb19009d216f4fb0f7911b939b2f1bc698e40c79.tar.gz
chip8-eb19009d216f4fb0f7911b939b2f1bc698e40c79.zip
SDL init stuff, test code
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..fd54795
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 3.5)
+cmake_minimum_required(VERSION 3.14)
+
+project(chip8 LANGUAGES C)
+ set(CMAKE_C_STANDARD 99)
+
+find_package(SDL2 REQUIRED)
+
+add_executable(
+ chip8
+ main.c)
+
+target_compile_options(chip8 PRIVATE -Wall)
+
+target_link_libraries(chip8 PRIVATE SDL2::SDL2)
+