summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Jones <admin@danieljon.es>2020-06-11 01:57:18 +0930
committerDaniel Jones <admin@danieljon.es>2020-06-11 01:57:18 +0930
commit1d38c1aa4c7fda8e55325783596df26e54a9777e (patch)
tree4b4b1f1f48c615ee2d0fa4dfa0d3e6452cbb216d /CMakeLists.txt
downloadfoxminesweeper-1d38c1aa4c7fda8e55325783596df26e54a9777e.tar.gz
foxminesweeper-1d38c1aa4c7fda8e55325783596df26e54a9777e.zip
initial progress
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..62ed893
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,23 @@
+cmake_minimum_required(VERSION 3.1)
+
+project(foxminesweeper)
+
+set(CMAKE_CXX_STANDARD 11)
+set(EXECUTABLE_OUTPUT_PATH ${CMAKE_BINARY_DIR}/bin)
+
+# Compiler Options
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -Wall")
+
+include_directories( /usr/include/fox-1.6 )
+
+add_executable(foxminesweeper
+ MainWindow.h
+ MainWindow.cpp
+ main.cpp
+ icons.h
+ Board.cpp
+ Board.h
+ Tile.cpp
+ Tile.h
+)
+target_link_libraries(foxminesweeper FOX-1.6)